ยังไม่มีสมาชิกที่ล็อกอินในขณะนี้
bulletบุคคลทั่วไป 4 คน
dot
dot
ชื่อผู้ใช้ :
รหัสผ่าน :
เข้าสู่ระบบอัตโนมัติ :
bullet ลืมรหัสผ่าน   bullet สมัครสมาชิก
dot




วิธีการเก็บ log file จาก Mikrotik โดย NSA210
Log File คือ อะไร
 
บางคนอาจสงสัยว่าเก็บไว้ทำไม ลองโหลดไปอ่านดูครับ >>>> พระราชบัญญัติว่าด้วยการกระทำผิดเกี่ยวกับคอมพิวเตอร์ พ.ศ.๒๕๕๐
 
เข้าใจง่ายๆ คือ เพื่อรู้ว่าผู้ที่ใช้ internet เราใช้ เนตทำอะไรที่ไหนบ้าง
เผื่อทำผิดกฏหมาย เช่น โพสหมิ่นประมาทคนอื่น โพสขายของตามเวปบอร์ดแล้วไม่ส่งของ หรือกระทำการผิดกฏหมาย ตาม พรบ.50

ถ้าเจ้าหน้าที่มาหา พร้อมขอหลักฐานการเก็บ log เราต้องมีให้ครับ
ไม่เช่นนั้นก็เป็นความผิดของเรา ถ้าหาผู้กระทำผิดไม่ได้ หรือบอกไม่ได้ว่าใครเป็นคนใช้ Internet ของเราทำผิด

สิ่งที่ต้องเก็บ และเก็บเพื่ออะไร

-account  / hotspot 
บอกว่า user นั้น login เมื่อไร logout เมื่อไร ได้ไอพีอะไร

-dhcp
บอกว่า IP ดังกล่าวมี Mac Address อะไร / ชื่อคอมที่ใช้ชื่ออะไร

-firewall
บอกว่า IP / User ดังกล่าวขณะนั้นใช้ port อะไรบ้าง

-web-proxy
บอกว่า IP นั้นเวลานั้นเข้าเวบอะไรบ้าง (เป็นหลักฐานสำคัญของ พรบ.50) อันนี้เท่าที่ลองกับรุ่นเล็ก-กลางๆ CPU ทำงานสูง แนะนำไม่ต้องเก็บครับ

ขั้นตอนการตั้งค่า NSA210 และ  Mikrotik เพื่อเก็บ log file
 
1.เซต IP ของ NSA210 ให้อยู่ในวงแลนเดียวกันกับ Mikrotik ตัวอย่าง Mikrotik ที่ผมใช้ gateway 192.168.1.1
ก็ตั้งเป็น 192.168.1.210 และเปิดพอร์ท 10000 ไว้สำหรับเรียกเข้ามาดูผ่าน dyndns


2.bypassed ให้ NSA210 ออกเนตได้โดยไม่ต้อง log in โดยไปที่ IP>>>Hotspot ตรง Host คลิ๊กขวาเลือก IP ของ NSA210


3.เอา HDD ที่ใส่ไป format กับ PC เพื่อให้ได้ partition เป็น NTFS
หรือใช้ NSA210 format จะได้ patition เป็น EXT3 ซึ่งเป็น linux หากจะเอาไปพ่วงบนวินโดว์ต้องใช้ Linux_Reader ในการดูข้อมูลครับ


4.ติดตั้ง Syslog โดยไปที่โปรแกรมสำเร็จรูป คลิ๊กที่ Syslog และเลือกติดตั้ง/อัพเกรดด้านบน



5.กด ตกลง เพื่อยืนยันการติดตั้ง

 
กรณีติดตั้งไม่ได้ อาจเพราะไม่ได้ bypass ให้ตัวอุปกรณ์ ผมใช้วิธีปิด hotspot ไปเลยครับง่ายดี 
ถ้าโหลดไม่สำเร็จให้ไปโหลดที่ตามลิงค์สำหรับ NSA210
 
 
อันนี้ของ NSA310
 
ให้ copy ไปวางที่ \\192.168.1.210\admin\zy-pkgs
192.168.1.210 คือ IP ของ NAS ครับถ้าไม่ใช้ IP นี้ให้เปลี่ยนตามด้วย วางไว้ในโฟลเดอร์ zy-pkgs
 
ปัญหา คือ มัน download จาก server ไม่ได้ เลยติดตั้งไม่ผ่าน

6.ติดตั้งเรียบร้อย


7.เลือกตำแหน่งที่เก็บไฟล์ log จำนวนการเก็บ (ในที่นี้ผมเก็บแค่ 3 เดือน) และรูปแบบการเก็บ



8.เปิด winbox log in เข้า Mikrotik


9.ไปที่เมนู System >>> Logging
เลือก Actions กด + จะมีหน้าต่าง New Log Action
Name:syslog
Type:remote
Remote Address:192.168.1.210
Remote Port:514

เสร็จแล้วกด OK



10.กด+ อีกรอบเพื่อสร้าง Webproxy Log หรือกด Copy ที่อยู่ใต้ Apply นั่นแหละ (ตัว Webproxy ถ้าลองเก็บแล้ว CPU ขึ้นสูงแนะนำไม่ต้องเก็บครับ)
ทำเหมือนกันกับข้างบน แต่เปลี่ยนชื่อ log
Name:Webproxy
Type:remote
Remote Address:192.168.1.210
Remote Port:514
 

11.จะได้ Log Actions 2 ตัว คือ 
Webproxy และ syslog Type:remote


12.ที่ Rules กด+ จะมีหน้าต่าง New Log Rule
Topics:account
Actions:syslog


12.สร้าง Log Rule เพิ่มอีก 3 อัน
คือ dhcp firewall และ hotspot โดย Action:syslog


13.สร้าง Log Rule wep-proxy Action เป็น Webproxy



14.จะได้ Rules Logging ตามรูป


15.ไปที่ IP>>>Hotspot ที่ User Profile
ติ๊กเครื่องหมายถูกตรง Transparent Proxy เพื่อให้ Proxy ใน Mikrotik ทำงาน



16.ไปที่ IP>>>Firewall ตรง Fiter Rules
กด + ที่ Action
Action:log กด Apply



17.ที่แท็บ General
Chain:forward
Out.Interface:pppoe-out1



18.อันนี้คือ Filter Rules log ที่เราสร้างขึ้นมาเมื่อกี้ครับ



19.ไปที่ Log จะเห็น Log วิ่ง ดูแทบไม่ทัน

 

20.วิธีเข้าดูก็ง่ายๆ กด start พิมพ์ \\ ตามด้วย IP ของ NSA210
หรือกด Windows+R ก็ได้
 


21.ตัว log file จะอยู่ตามตำแหน่งที่เราให้เก็บตามข้อ 7
เปิดดูด้วย Notepad หรือ Notepad++ จะดูง่ายกว่าครับ

 
วิธีการอีกแบบครับ copy วางใช้ได้เลย เปลี่ยน ip ของ NAS
 
/system logging action
add name=syslog remote=192.168.1.210 target=remote
add name=Webproxy remote=192.168.1.210 target=remote
/system logging
add action=Webproxy topics=web-proxy
add action=syslog topics=account
add action=syslog topics=dhcp
add action=syslog topics=hotspot
add action=syslog topics=firewall

/ip firewall filter
add action=log chain=forward out-interface=pppoe-out1
add action=log chain=forward out-interface=pppoe-out2 หรือ interface ที่ต้องการ กรณีใช้มากกว่า 1 WAN
 
ขอสคริปท์ได้ที่ webmaster@wifi4you.com ครับ
 
โดย log file จำเป็นต้องนำไปวิเคราะห์ร่วมกับข้อมูลการโพสในเวปบอร์ดหรือการกระทำที่ผิดตาม พรบ.50
มีไว้ดีกว่าไม่มีครับ คงไม่มีใคร ไม่ได้ทำผิดแล้วตกเป็นแพะ
แต่ถ้าไม่มี คือ ยังไงก็เป็นคนทำผิดอยู่แล้ว
 
หวังว่าคงไม่มีท่านใดงานเข้าเพราะไม่ได้เก็บ log file นะครับ
 
สำหรับวันนี้ สวัสดีครับ



ง่ายๆ สนุกๆ กับการตั้งค่าอุปกรณ์ โดย ช่างอำพล

Spyware on Mikrotik
userman สำหรับ CPU ARM,MMIPS มาแล้ว
ACB-AC
Soft RESET & Hard RESET Mikrotik
RB1100AHx4 Dude Edition
UVC G3+LED
PPC Load Balance Mikrotik
RB3011UiAS-RM อยากมี userman
airOS 8 กับ airOS 6
วิธีการเปลี่ยนหน้า login hEX Series
ER-X vs ER-X-SFP
PPPoE Server Mikrotik
RB850Gx2
Edge Switch vs UniFi Switch
upgrage airVisionNVR to UniFiNVR
RB450G ROSv6.x can not downgrade to 5.x
UniFi Video
แนะนำ Device Mikrotik
RB450G+RB2011UiAS-RS232
ALFA Wireless USB adapter FOR MAC OSX
วิธีการเพิ่ม IP Pool Mikrotik
Class Mikrotik RouterBoard
อัพ Firmware AIP-W525Hv2
Mikrotik RB750UP
UBIQUITI TOUGHSwitch PoE
TestDrive AIP-W525Hv2
036NHRv2
airVision2 NVR
AIP-W525Hv2@TRUEWIFI
อยากให้เธอลอง AIP-W525H v2
Tube2H 802.11n Long-Rang Outdoor AP/CPE
Backup ค่า config Mikrotik
Channel Overlap
Mikrotik Send IP TO EMAIL V.2
UBiQUiTi TOUGHCable PRO
no-ip กับ Mikrotik
อัพ firmware AIP-W525H
วิธีการเปลี่ยน IP Mikrotik
WISP-NSR Low-Cost Outdoor CPE
POE MoD
Multiwan Ratio
วิธีแก้ปัญหาเบื้องต้นตัวรับ USB Wireless
Userman v.5.xx Mikrotik
Downgrade ROS Mikrotik
รีวิว USB Outdoor เสา Panel
รวม Internet 4 เส้น แบบ 4 PPPoE และ 2 PPPoE+2 static to 1 LAN
static IP กับยอมให้ client ที่รับ dhcp เท่านั้นใช้งาน Internet ได้
Mikrotik Send IP TO EMAIL
Tower สูงกับการเลือกช่องความถี่ของ AP
ปลุกน้องติ๊ก RB Series7
FAQ PowerMax AIP-W515H/AIP-W525H
Mikrotik 4wan static load balance
ระบบบันทึก Motion Record AirCamDome
Mikrotik 1 WAN PPPoE พร้อม Hotspot
ต่อเนตให้น้องติ๊กโดย Default Config
support ผ่าน internet
เริ่มต้น ROS Mikrotik
วิธีเปิดใช้งาน POE Passthrough อย่างถูกต้อง
เลือกตัวรับ USB Hi Power ให้เหมาะสมกับงาน
airCam และ airCam Dome
รีวิว ALFA 036NHA 800mW b/g/n MIMO
รีวิวกึ่งทดสอบ CPE Outdoor Tube-U รุ่น N และ G
AIP-W411 firmware dd-wrt
WDS
เปลี่ยนตัวรับสัญญาณ ALFA USB เป็น AP
PowerMax515 Repeater
วิธีการตั้งค่า ALFA AWAP-411 และ AWIP-W411
ฟังค์ชั่น QOS PowerMax515 และ 525
Bridge Mode+PPPoE Loco M2
PowerMax525 ตั้งค่าแบบบ้านๆกัน
HomePlug AHPE303
PowerMax AIP-W525H Universal Repeater
ฟิก ip