ยังไม่มีสมาชิกที่ล็อกอินในขณะนี้
bulletบุคคลทั่วไป 5 คน
dot
dot
ชื่อผู้ใช้ :
รหัสผ่าน :
เข้าสู่ระบบอัตโนมัติ :
bullet ลืมรหัสผ่าน   bullet สมัครสมาชิก
dot




Backup ค่า config Mikrotik
ปกติบางท่านที่พึ่งลองหัดเล่น Mikrotik ส่วนใหญ่จะเล่นรุ่นเล็กๆ เช่นพวก RB750 RB750GL (ROS L.4)
ซึ่งจะรองรับ user ได้ไม่มาก เมื่อต้องการเปลี่ยนเป็นรุ่นระดับกลางๆ เช่น RB450G (ROS L.5 50 user)
จะทำยังไง  สำหรับการ backup ค่าคอนฟิกข้ามรุ่น ทำได้กับ V.เดียวกันครับ คือ V.5.xx ใช้ด้วยกันได้

วิธีที่ผมทำ ตัวอย่างผมย้ายจาก RB750 (V.5.21) ไป RB450G (V.5.23)สั่งมาใหม่ก็อัพ ROS ตัวล่าสุดไปเลย
 
 
คำสั่งที่ใช้ คือ export compact ซึ่งใช้ได้ตั้งแต่ v5.12 เป็นต้นมาครับ
พิมพ์ export compact ใน Termimal



ตัว Terminal จะเก็บสคริปท์ทุกอย่างไว้ สำหรับเอาไปลงตัวอื่น ข้ามรุ่นได้ (ส่วนตัวผมยังไม่เคยลองเทสกับรุ่นใหญ่ๆพวก RB1100 RB1200 นะครับ)
ข้ามรุ่น เช่นจากรุ่นที่มีไวเลส ควรเช็ค interface ด้วยครับ
ข้ามรุ่นอย่างไปหา RB1100AHx2 หรือ CCR มันมี Switch 2 ชุด ทำ Master Port ไม่ได้
ต้องเซตเพิ่มทีหลัง


ใช้ copy all แล้วมาตัดท่อนบนที่เป็น Mikrotik และท่อนล่างบรรทัดสุดท้ายออก
หรือจะ hiligth เอาเฉพาะท่อนที่ใช้จริงก็ได้



เอาไปวางใน Notepad++ หรือ WORD ครับ ตัดออกถึงบรรทัด 27


RB450G ก่อนอื่นให้ไปที่ System>>>Reset configuration
ติ๊กตรง No Default Configuration เพื่อล้างค่ามาตรฐานที่มาพร้อม Mikrotik ออกไป
ตัว RB750 และ RB450G ผมลง routeros-mipsbe และอัพเฉพาะ  user-manager (ทั้งสองตัวเหมือนกัน ต่างที่เวอร์ชั่นครับ)



สังเกตุง่ายๆถ้าไม่มีค่า Default ติดมาตอน login จะเห็น IP เป็น 0.0.0.0
ต้องคอนเนตผ่าน MAC ADDRESS เท่านั้น


ไปที่ Terminal Paste script โดยผมตัดส่วนหัวด้านบนออกแล้ว


เพิ่มเติม ภายใต้
/interface ethernet
set 2 master-port=ether2
set 3 master-port=ether2
set 4 master-port=ether2
 
ให้ลบออกครับ หรือเอาไปต่อท้ายสุด ลองสังเกตุจาก หลังจาก Paste Script มันจะค้างและ Reboot ที่บรรทัดนี้ 
เซต PORT ให้เป็น Master กับ  Port หรือรอเซตทีหลังได้ครับ
 

ให้สังเกตุ ถ้ามีสคริปท์บรรทัดไหน มี command line แจ้ง error แสดงว่าสคริปท์เดิมที่ใช้อยู่ก็มีปัญหาอยู่
ในรูปลืมเอาบรรทัดสุดท้ายออกครับ


ทดสอบแล้วใช้งานได้ทั้งตัว user ที่สร้างจาก winbox และ userman ทำงานได้ครบครับ 
แต่สิ่งที่ผมสังเกตุเห็น คือ password login เข้า Mikrotik ที่ผมตั้งไว้แล้ว
ไม่ได้ติดมาครับ ต้องตั้งใหม่

การ backup เฉพาะส่วน
สมมุติว่าไฟล์ backup userman ผมตั้งเป็น 20022013 นามสกุลมันจะ .umb
To backup...

/tool user-manager database save name=20022013

To restore...

/tool user-manager database load name=20022013

ตัวอย่างการ backup แบบเก่า

system backup save name=20022013 แล้วกด Enter

Restore คำสั่งนี้ใช้ คืนค่าเดิมในกรณี คืนค่าลงในตัวเดิมครับ

system backup load name=20022013 แล้วกด Enter
พิมพ์ Y เพื่อยืนยันการ Restore ข้อมูล

เมื่อ MikroTik restore เสร็จ จะทำการ Reboot 1ครั้ง

Backup Source (เพื่อเก็บไว้ดูคำสั่งทั้งหมดผ่าน Terminal)ไว้สำหรับย้ายค่าข้ามรุ่น
เข้าเมนู Terminal 
export file=20022013 แล้วกด Enter

เข้าไปดูได้ที่เมนู File > File list ก็จะมีชื่อไฟล์ที่เรา export (นามสกุล .rsc)
สามารถเอาไปแก้กับ Notepad++ หรือ word ได้เช่นกัน โดยลบ config ที่อยู่ภายใต้
/interface ethernet ออกครับ เพราะมันจะมี MAC ADDRESS ของอุปกรณ์ตัวเดิมอยู่ แต่ส่วนใหญ่ผมใช้ export compact ดีกว่าครับ
 

เครดิตที่มา จาก wiki ของ Mikrotik



ง่ายๆ สนุกๆ กับการตั้งค่าอุปกรณ์ โดย ช่างอำพล

Spyware on Mikrotik
userman สำหรับ CPU ARM,MMIPS มาแล้ว
ACB-AC
Soft RESET & Hard RESET Mikrotik
RB1100AHx4 Dude Edition
UVC G3+LED
PPC Load Balance Mikrotik
RB3011UiAS-RM อยากมี userman
airOS 8 กับ airOS 6
วิธีการเปลี่ยนหน้า login hEX Series
ER-X vs ER-X-SFP
PPPoE Server Mikrotik
RB850Gx2
Edge Switch vs UniFi Switch
upgrage airVisionNVR to UniFiNVR
RB450G ROSv6.x can not downgrade to 5.x
UniFi Video
แนะนำ Device Mikrotik
RB450G+RB2011UiAS-RS232
ALFA Wireless USB adapter FOR MAC OSX
วิธีการเพิ่ม IP Pool Mikrotik
Class Mikrotik RouterBoard
อัพ Firmware AIP-W525Hv2
Mikrotik RB750UP
UBIQUITI TOUGHSwitch PoE
TestDrive AIP-W525Hv2
036NHRv2
airVision2 NVR
AIP-W525Hv2@TRUEWIFI
อยากให้เธอลอง AIP-W525H v2
Tube2H 802.11n Long-Rang Outdoor AP/CPE
Channel Overlap
Mikrotik Send IP TO EMAIL V.2
UBiQUiTi TOUGHCable PRO
no-ip กับ Mikrotik
อัพ firmware AIP-W525H
วิธีการเปลี่ยน IP Mikrotik
WISP-NSR Low-Cost Outdoor CPE
POE MoD
Multiwan Ratio
วิธีแก้ปัญหาเบื้องต้นตัวรับ USB Wireless
Userman v.5.xx Mikrotik
Downgrade ROS Mikrotik
รีวิว USB Outdoor เสา Panel
รวม Internet 4 เส้น แบบ 4 PPPoE และ 2 PPPoE+2 static to 1 LAN
static IP กับยอมให้ client ที่รับ dhcp เท่านั้นใช้งาน Internet ได้
Mikrotik Send IP TO EMAIL
Tower สูงกับการเลือกช่องความถี่ของ AP
วิธีการเก็บ log file จาก Mikrotik โดย NSA210
ปลุกน้องติ๊ก RB Series7
FAQ PowerMax AIP-W515H/AIP-W525H
Mikrotik 4wan static load balance
ระบบบันทึก Motion Record AirCamDome
Mikrotik 1 WAN PPPoE พร้อม Hotspot
ต่อเนตให้น้องติ๊กโดย Default Config
support ผ่าน internet
เริ่มต้น ROS Mikrotik
วิธีเปิดใช้งาน POE Passthrough อย่างถูกต้อง
เลือกตัวรับ USB Hi Power ให้เหมาะสมกับงาน
airCam และ airCam Dome
รีวิว ALFA 036NHA 800mW b/g/n MIMO
รีวิวกึ่งทดสอบ CPE Outdoor Tube-U รุ่น N และ G
AIP-W411 firmware dd-wrt
WDS
เปลี่ยนตัวรับสัญญาณ ALFA USB เป็น AP
PowerMax515 Repeater
วิธีการตั้งค่า ALFA AWAP-411 และ AWIP-W411
ฟังค์ชั่น QOS PowerMax515 และ 525
Bridge Mode+PPPoE Loco M2
PowerMax525 ตั้งค่าแบบบ้านๆกัน
HomePlug AHPE303
PowerMax AIP-W525H Universal Repeater
ฟิก ip