ยังไม่มีสมาชิกที่ล็อกอินในขณะนี้
bulletบุคคลทั่วไป 5 คน
dot
dot
ชื่อผู้ใช้ :
รหัสผ่าน :
เข้าสู่ระบบอัตโนมัติ :
bullet ลืมรหัสผ่าน   bullet สมัครสมาชิก
dot




RB3011UiAS-RM อยากมี userman

สวัสดีครับ วันนี้นี้บทความประยุกต์หรือ DIY ให้ RB3011UiAS-RM สามารถใช้ userman ได้ 
อันนี้สามารถดัดแปลงใช้กับ RB750Gr3,RB1100AHx4 Dude Edition ได้ด้วยครับ

#แก้ไข ข้อมูลนี้เขียนเมื่อ 24/3/2017
userman สำหรับ CPU ARM,MMIPS เขียนไว้เมื่อ 9/3/2018
http://www.wifi4you.com/Amp/userman.html

สรุปมันสามารถใช้ userman ได้แล้วครับ 

userman หรือ user-manager คือระบบจัดการวันหมดอายุของคูปอง
เช่น บัตรรายวัน 1 วัน ใช้ได้ 1 วัน,30 วันก็ใช้ได้ 30 วัน
แต่ถ้าเป็น user ที่สร้างจาก winbox จะกำหนดได้แค่ความเร็วครับ วันหมดอายุต้องมานับ กด disable เอง

ในรุ่น RB3011UiAS-RM และ RB750Gr3 โดนตัด userman ออกไป
บาง Site ที่ออกคูปองขายรายวัน มันเลยต้องเช่า radius นอก
ซึ่งค่าบริการรายเดือน อย่างต่ำ 20 user active=200 x12=2,400
ก็ถือว่าแพงเหมือนกันครับ

ผมได้วิธีการนี้มาจากในกลุ่มที่ใช้ mikrotik ว่างๆอีกตัว มาทำ userman แทน
เช่น
Level4 20 user active=RB750r2(ราคามือสองพวก RB750 Series ไม่เกิน 800)
Level5 50 user active=RB450G(ราคามือสอง RB450G เคยเห็น 1,500 หรือพวกซากโดนไฟกระชาก แลนเสียเป็นบางช่อง ขายไม่เกิน 1,000)
Level 6 unlimit active = RB1100AHx2 ,X86(ตรงนี้จะสายมืด หรือจะสนับสนุน RouterOS Licenses ของแท้ก็ดีครับ 5,000)

Diagram ผมเป็นแบบนี้ครับ เบิก RB450G มาพ่วงอีกตัว

RB3011UiAS-RM=WAN เป็น PPPoE,Static IP หรือ DHCP แล้วแต่หน้างานที่ทำได้
#ether1=PPPoE
#ether2,ether6=Bridge 192.168.100.1/24
#ether3-5=Master Port ether2
#ether7-10=Master Port ether6

RB450G=192.168.100.2/24 ether1 รับ DHCP จาก RB3011UiAS-RM
ตัวนี้ผมต่อกับ ether10 เลย จะได้ไม่ต้องใช้อะแด็ปเตอร์

เริ่มจาก RB450G ก่อน
1.หลังจากได้อุปกรณ์มา ให้ upgrade packet เป็น 6.37.5(bugfix only)
***สาเหตุที่ไม่แนะนำเวอร์ชั่นล่าสุด เพราะมันมีปัญหาเกียวกับ profile userman คือสร้างได้ profile เดียว
รุ่นเล็กอย่าง hEX Series อย่าลง packages เต็มนะครับ Stores มี 16 MB ลงเต็มแล้วจะเหลือ 1 MB นิดๆ เดี๋ยว user ที่สร้างจาก userman จะเต็มไว
RB750,RB750GL,RB750UP,RB450G พวกนี้เยอะครับ

2.เลือก Reset Configguration ติ๊ก No Default Configuration เราไม่เอาคอนฟิกใดๆทั้งสิ้น



3.login ผ่าน MAC Addressg เข้า New Terminal วางสคริปท์เลย
อธิบายสคริปท์ static IP ให้ ether1 ,เปลี่ยน port www เป็น 82,ปิดที่ไม่ได้ใช้
หา IP ของ 3011 เป็นตัวอื่นก็เปลี่ยนกลุ่ม IP ตามครับ เช่น 10.5.50.1/24 เป็น 10.5.50.2/24

/ip address
add address=192.168.100.2/24 interface=ether1 network=192.168.100.0
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=82
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes

สลับกลับมาเซต RB3011UiAS-RM ก่อนครับ

1.เช่นเดียวกันครับ หลังได้อุปกรณ์ ที่กล่องระบุให้อัพเกรด ROS เป็นล่าสุด เพื่อประสิทธิภาพครับ
ซึงตรงนี้ผมใช้ bugfix only เช่นกัน

2.เลือก Reset Configuration ติ๊ก No Default Configuration 
ขั้นตอนนี้เหมือน RB450G คือผมให้ตัว Mikrotik ลบค่าคอนฟิกมาตรฐานและติดตั้ง packages ลงไปพร้อมกับ boot ขึ้นมาใหม่

3.login ผ่าน MAC Address วางสคริปท์เลยครับ
อธิบายสคริปท์ สร้าง pppoe-client ที่ ether1,สร้าง Bridge1,+ether2-5 ether7-10 และ SFP1 เป็นสมาชิกใน Bridge1,bypass IP 192.168.100.2 

/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
set [ find default-name=ether7 ] master-port=ether6
set [ find default-name=ether8 ] master-port=ether6
set [ find default-name=ether9 ] master-port=ether6
set [ find default-name=ether10 ] master-port=ether6
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=ppp1 \
    use-peer-dns=yes user=ppp1
/ip hotspot profile

add hotspot-address=192.168.100.1 name=hsprof1 use-radius=yes
/ip pool
add name=hs-pool-13 ranges=192.168.100.2-192.168.100.254
/ip dhcp-server
add address-pool=hs-pool-13 disabled=no interface=bridge1 lease-time=1h name=dhcp1
/ip hotspot
add address-pool=hs-pool-13 disabled=no interface=bridge1 name=hotspot1 profile=hsprof1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=sfp1
/ip address
add address=192.168.100.1/24 comment="hotspot network" interface=bridge1 network=\
    192.168.100.0
/ip dhcp-server network
add address=192.168.100.0/24 comment="hotspot network" gateway=192.168.100.1
/ip firewall nat
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=\
    192.168.100.0/24
/ip hotspot ip-binding
add address=192.168.100.2 server=hotspot1 to-address=192.168.100.2 type=bypassed
/ip hotspot user
add name=admin
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=81
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/radius
add address=192.168.100.2 secret=123456 service=hotspot

/system clock
set time-zone-name=Asia/Bangkok

ตรงนี้ไม่ลงรูปนะครับ ทำผ่าน New Terminal ง่ายๆ
ถ้าทำผ่าน ทดสอบ ping 192.168.100.1 ใน RB450G และ 192.168.100.2 ใน RB3011UiAS-RM ต้องไม่ time out ครับ
หาก WAN ของ 3011 เป็น pppoe-client อย่าลืมเปลี่ยน user/password ของผู้ดูแลระบบด้วยนะครับ

ถ้าสังเกตุอีกจะเห็นว่าในสคริปท์ด้านบน
ผม
เปิดใช้ RADIUS ใน Server Profiles แล้วไขว่ Radius เป็น 192.168.100.2 (จากเดิมเราใส่ 127.0.0.1 จำได้หรือไม่)
แล้วในตัว RB450G เราจะใส่คืนเป็น 192.168.100.1 ใส่ Secret ให้ตรงกัน



ต่อที่การเซต userman ใน RB450G
กำหนด Radius ใน winbox ถ้าเป็นสคริปท์ก็สั้นๆ
/radius
add address=192.168.100.1 secret=123456 service=hotspot



userman ผมเปลี่ยน service port www เป็น 82 แล้ว ก็เข้า 192.168.100.2:82/userman
เดี๋ยวทวนการเซต userman ให้สั้นๆ
1.Routers>ชื่อ radius ตามที่กำหนด,IP Address ต้องเป็นของ 3011 คือ 192.168.100.1,secret ตรงกัน,Time zone +07:00
เสร็จแล้ว add

2.Customers จะเปลี่ยน password ผู้ดูแลระบบก็เปลี่ยนตรงนี้เลย
Currency=THB หรือกีบ หยวน $ ก็จัดไป สำคัญอย่าลืม Time zone +07:00 เสร็จแล้ว Save


3.Profiles>Limitation details กำหนด ชื่อ,ความเร็วในที่นี้ผมให้เป็น 10M/512k ครับ เสร็จแล้ว add
ตรงนี้จะทำ Profile ก่อนก็ได้ แต่หน้าจอผมกำหนดไว้ 800x600 มันกว้างไม่พอครับ

4.Profiles>ชื่อ packet,วันใช้งาน,ราคาขาย แล้ว add เข้ากับ limitation

5.ลองสร้าง user เทสดูครับ

6.ผ่าน สถานะ R คือ login ผ่าน radius ใน [ที่เป็นเหมือน radius นอก]


ทิปนิดๆครับ
MAC Cookie มันอยู่ 3 วัน เยอะไปหรือเปล่า
ที่เหมาะสมผมว่าควรจะไม่เกิน 1 วัน หรือ 12 ชั่วโมงครับ ตรงนี้ลดหรือปิดไม่ใช้เลยก็ได้



HTTP Cookie เหมือนกันครับ



สุดท้ายสำหรับใครที่โลภมาก ผมลองเทสให้แล้วครับ

RB3011UiAS-RM=1 ตัว+RB450G 1 ตัว และ RB750Gr2 2 ตัว รวมเป็น 3 ตัว
ว่าจะทำ Level 5 ครึ่ง 50+20+20=[90 active] ไม่ผ่านครับ




-RADIUS ทำงานจากบนลงล่าง
พ่วงไว้หลายๆตัวได้ แต่มันทำงานได้ทีล่ะตัว ลองลาก 4 ขึ้นบนใช้ได้ แต่ user จาก 2 อยู่ล่างใช้ไม่ได้ 3 และ 4 ล่ม 2 จึงจะใช้ได้
-ในส่วนของ nas หรือ database สามารถใช้รวมกันได้
ตัวอย่าง ผมมี CCR1036-8G-2S+ และ RB3011UiAS-RM 5 ตัว
สามารถเซต PPTP Server Binding ที่ตัว CCR1036 แล้วให้ 3011 VPN เข้ามาใช้ userman ที่ตัวหลักได้
หลักการเซตเหมือนกัน แต่มีเพิ่ม firewall,nat,routing ให้ตัว mikrotik ทั้งสองฝั่งเห็น IP ของ radius
วิธีการนี้ก็เหมือน server radius ที่ให้เช่าครับ แต่มันเป็น mikrotik

ลองๆไปดัดแปลงดูครับ หาชอบบทความหรือรีวิว ช่วยกด Like หรือ Share เป็นกำลังใจให้ด้วยนะครับ

support@wifi4you.com
24/3/2017

ediit 27/6/2018




ง่ายๆ สนุกๆ กับการตั้งค่าอุปกรณ์ โดย ช่างอำพล

Spyware on Mikrotik
userman สำหรับ CPU ARM,MMIPS มาแล้ว
ACB-AC
Soft RESET & Hard RESET Mikrotik
RB1100AHx4 Dude Edition
UVC G3+LED
PPC Load Balance Mikrotik
airOS 8 กับ airOS 6
วิธีการเปลี่ยนหน้า login hEX Series
ER-X vs ER-X-SFP
PPPoE Server Mikrotik
RB850Gx2
Edge Switch vs UniFi Switch
upgrage airVisionNVR to UniFiNVR
RB450G ROSv6.x can not downgrade to 5.x
UniFi Video
แนะนำ Device Mikrotik
RB450G+RB2011UiAS-RS232
ALFA Wireless USB adapter FOR MAC OSX
วิธีการเพิ่ม IP Pool Mikrotik
Class Mikrotik RouterBoard
อัพ Firmware AIP-W525Hv2
Mikrotik RB750UP
UBIQUITI TOUGHSwitch PoE
TestDrive AIP-W525Hv2
036NHRv2
airVision2 NVR
AIP-W525Hv2@TRUEWIFI
อยากให้เธอลอง AIP-W525H v2
Tube2H 802.11n Long-Rang Outdoor AP/CPE
Backup ค่า config Mikrotik
Channel Overlap
Mikrotik Send IP TO EMAIL V.2
UBiQUiTi TOUGHCable PRO
no-ip กับ Mikrotik
อัพ firmware AIP-W525H
วิธีการเปลี่ยน IP Mikrotik
WISP-NSR Low-Cost Outdoor CPE
POE MoD
Multiwan Ratio
วิธีแก้ปัญหาเบื้องต้นตัวรับ USB Wireless
Userman v.5.xx Mikrotik
Downgrade ROS Mikrotik
รีวิว USB Outdoor เสา Panel
รวม Internet 4 เส้น แบบ 4 PPPoE และ 2 PPPoE+2 static to 1 LAN
static IP กับยอมให้ client ที่รับ dhcp เท่านั้นใช้งาน Internet ได้
Mikrotik Send IP TO EMAIL
Tower สูงกับการเลือกช่องความถี่ของ AP
วิธีการเก็บ log file จาก Mikrotik โดย NSA210
ปลุกน้องติ๊ก RB Series7
FAQ PowerMax AIP-W515H/AIP-W525H
Mikrotik 4wan static load balance
ระบบบันทึก Motion Record AirCamDome
Mikrotik 1 WAN PPPoE พร้อม Hotspot
ต่อเนตให้น้องติ๊กโดย Default Config
support ผ่าน internet
เริ่มต้น ROS Mikrotik
วิธีเปิดใช้งาน POE Passthrough อย่างถูกต้อง
เลือกตัวรับ USB Hi Power ให้เหมาะสมกับงาน
airCam และ airCam Dome
รีวิว ALFA 036NHA 800mW b/g/n MIMO
รีวิวกึ่งทดสอบ CPE Outdoor Tube-U รุ่น N และ G
AIP-W411 firmware dd-wrt
WDS
เปลี่ยนตัวรับสัญญาณ ALFA USB เป็น AP
PowerMax515 Repeater
วิธีการตั้งค่า ALFA AWAP-411 และ AWIP-W411
ฟังค์ชั่น QOS PowerMax515 และ 525
Bridge Mode+PPPoE Loco M2
PowerMax525 ตั้งค่าแบบบ้านๆกัน
HomePlug AHPE303
PowerMax AIP-W525H Universal Repeater
ฟิก ip